Ubuntu 16.04.02 Hang on Reboot or Shutdown

Had a problem after an update that when I force a restart or a shutdown on my server, it hangs on the last part of the process.

To fix my problem, I had to edit the /etc/default/grub config file and added acpi=force apm=power_off to the config line, between the double quotation marks…

1
GRUB_CMDLINE_LINUX_DEFAULT=""

and

1
GRUB_CMDLINE_LINUX=""

do a update-grub after saving then reboot one more time.. ( force sa restart when it hangs )
After the restart, try another reboot, it should work now without hanging.

Source of the fix is from Here

Shrink/Compact and Re-size VMWare Image in VMWare Player

I had an office PC converted into a VMWare image and wanted to reduce the image file after cleaning up unwanted files and applications. The compact command for the HDD will not totally reduce the image file size in the HOST OS.

VM Image OS is Windows XP. For linux, I will assume a different process.

To literally reduce file size in the host OS, what I did…

  1. Free up disk space.
  2. Zero fill freed up space, I used CCleaner
  3. Shutdown the VM
  4. Run again VMWare Player and right click on the VM
  5. Go to Hard Disk and under Utilities -> Compact
  6. Finish the compact phase and start the VM again.
  7. Install any Partitioning software, I used EaseUS.
  8. After completing the installation, re-size the Hard Disk that has the freed up space to a smaller space that you want
  9. Apply the re-reize
  10. Shutdown the VM, the actual size on the Host OS will now have the reduced file size.

You can expand the size again of the partition/hard disk using the partitioning software and it will not affect the actual VM image file size in the host OS until you start adding new files/data into it.

VMWare Sphere 5 Boot Delay

Update: This will also work for 5.1 and 5.5.

Note, this is a WhiteBox setup so not all parts are officially supported by VMWare. Specs below…

  • i7 2600K
  • Gigabyte P67A-UD4 B3
  • 8GB DDR3-1866hz 9-9-9
  • 1TB Samsung F3 drives
  • Intel Gigabit Network card

Now, the issue here is that after a clean install of VMWare Sphere 5, boot-up would take at least 5-9 min to complete from a clean power-on. Compared to an upgrade from VMWare Sphere 4.1U1 which will load all the necessary drivers right away after a restart/power-on. It seems like its not detecting the HDD at all at first glance but soon found its way. Further tests, experiments and research yielded that this is a side-effect on how VMWare handled their installation process in VMWare Sphere 5 compared to 4.1U1. In 4.1U1, it uses the MBR for the boot process by default, while in 5.0 it uses GPT. You can fixed this if you force the installer to use MBR during the installation phase.
Continue Reading